Project

General

Profile

Feature #4046

Form: enable/hide/lock/unlock delete Button - sqlStateDeleteButton

Added by Carsten Rose over 4 years ago. Updated 7 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
04.07.2017
Due date:
% Done:

0%

Estimated time:
Discuss:

Description

On the Form a parameter:

sqlStateDeleteButton={{SELECT IF(.., 'enabled', 'disabled')}}

might protect records, which should not be deleted.

Query should 'dynamic Update' aware.


Related issues

Is duplicate of QFQ - Feature #12262: Form buttons on top: more customableNewCarsten Rose25.03.2021

Actions
#1

Updated by Carsten Rose over 4 years ago

  • Description updated (diff)
#2

Updated by Carsten Rose about 4 years ago

  • Target version set to next4
#3

Updated by Carsten Rose about 4 years ago

  • Tracker changed from Support to Feature
#4

Updated by Carsten Rose over 2 years ago

  • Subject changed from Form: lock/unlock delete Button - sqlStateDeleteButton to Form: enable/hide/lock/unlock delete Button - sqlStateDeleteButton
#5

Updated by Carsten Rose almost 2 years ago

  • Status changed from New to Some day maybe
#6

Updated by Carsten Rose 7 months ago

  • Is duplicate of Feature #12262: Form buttons on top: more customable added
#7

Updated by Carsten Rose 7 months ago

  • Status changed from Some day maybe to Rejected
#8

Updated by Carsten Rose 7 months ago

  • Target version deleted (next4)

Also available in: Atom PDF