Project

General

Profile

Bug #4724

mode=requiredOff: bei dynamicUpdate wird required troztdem abgefragt.

Added by Karin Niffeler almost 3 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
High
Assignee:
Target version:
Start date:
06.10.2017
Due date:
% Done:

0%

Estimated time:
Discuss:

Description

Hi Carsten

...
Bei dynamischen Updates (after insert und after save) erhalte ich trotz “mode=requiredOff” eine Fehlermeldung (Problem02 / qfq 23.3)
...

Problem02.pdf (505 KB) Problem02.pdf Karin Niffeler, 06.10.2017 16:22
Screen Shot 2017-10-11 at 09.51.40.png (322 KB) Screen Shot 2017-10-11 at 09.51.40.png Karin Niffeler, 11.10.2017 09:52
948

Related issues

Related to QFQ - Bug #4731: Dynamic Update: load(post) triggers 'check required' - makes no sense during filling a formClosed2017-10-09

Related to QFQ - Bug #5077: 'Required' FormElement mit Dynamic UpdateClosed2017-12-09

History

#1 Updated by Carsten Rose almost 3 years ago

  • Project changed from IT to QFQ
  • Subject changed from qfq 23.3 / qfq 23.4 to mode=requiredOff: bei dynamicUpdate wird required troztdem abgefragt.
  • Assignee set to Carsten Rose
  • Target version set to 0.24

#2 Updated by Carsten Rose almost 3 years ago

  • File deleted (Problem01.pdf)

#3 Updated by Carsten Rose almost 3 years ago

  • File deleted (Problem03.pdf)

#4 Updated by Carsten Rose almost 3 years ago

  • Description updated (diff)

#5 Updated by Carsten Rose almost 3 years ago

  • Tracker changed from Support to Bug

#6 Updated by Carsten Rose over 2 years ago

  • Related to Bug #4731: Dynamic Update: load(post) triggers 'check required' - makes no sense during filling a form added

#7 Updated by Carsten Rose over 2 years ago

  • Status changed from New to Ready to sync (develop)
  • Assignee changed from Carsten Rose to Karin Niffeler

Hallo Karin

Der Bug sollte in 0.24.0 (released) gefixt sein.

Es wird gleich eine 0.25.0 geben, mit einer Aenderung bei der Konfigurationsdatei: nimm bitte trotzdem die 0.24.0.

Wenn der Bug gefixt ist, Ticket bitte schliessen, sonst wieder mir zuordnen.

CU
Carsten

#8 Updated by Karin Niffeler over 2 years ago

948

Guten Morgen Carsten

Vielen Dank. Es funktioniert nun fast.

Es gibt nur noch ein kleines Problem. Wenn Formularfelder dynamisch sind und zum Beispiel nur angezeigt werden sollen, wenn ein gewisses Masterprogramm ausgewählt ist, funktioniert die "Required-Funktion" nach "save" nicht. Das heisst, das Formular kann gespeichert werden, ohne dass diese "Required-Felder" ausgefüllt sind (siehe Attachment - Feld "Topic BME520:*").

Im Mode sql gibt es zum Beispiel folgenden Befehl: {{SELECT IF }}

Installiert habe ich nun qfq 0.25.0

LG
Karin

#9 Updated by Karin Niffeler over 2 years ago

  • Priority changed from Normal to High

#10 Updated by Carsten Rose over 2 years ago

  • Target version changed from 0.24 to 0.25

#11 Updated by Carsten Rose over 2 years ago

  • Target version changed from 0.25 to next

#12 Updated by Carsten Rose about 2 years ago

  • Related to Bug #5077: 'Required' FormElement mit Dynamic Update added

#13 Updated by Carsten Rose about 2 years ago

  • Status changed from In Progress to Closed

Hallo Karin

ist in der 18.6.0 gefixt.

Achtung: es gibt Aenderungen in der Konfigurationsdatei - ggfs. mit mir einen Termin absprechen (damit wir das zusammen machen) falls du die neueste Version installieren moechtest.

CU
Carsten

#14 Updated by Carsten Rose about 2 years ago

  • Target version changed from next to 18.6.0

#15 Updated by Karin Niffeler about 2 years ago

Guten Morgen Carsten

Vielen Dank. Würde es Dir beispielsweise am Donnerstag 21. Juni entweder um 10:00 Uhr oder 13:00 Uhr für die Installation passen?

LG
Karin

Karin Niffeler
E-Learning Koordinatorin Fachbereich Biologie

Y 34 J 06
University of Zurich
Winterthurerstrasse 190
8057 Zurich
Switzerland

Tel: +41 (0) 44 63 54859
<mailto:>

On 13 Jun 2018, at 16:44, wrote:

Also available in: Atom PDF