Project

General

Profile

Bug #7013

Messed up query numbering

Added by Nicola Chiapolini about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
16.10.2018
Due date:
% Done:

0%

Estimated time:
Discuss:

Description

(Running version: qfq 18.6.1)


1.sql = SELECT name AS _first FROM Form LIMIT 1
10.sql = SELECT name AS _second FROM Form LIMIT 1
10.1.sql = SELECT "hallo {{second:R::s}}"
10.1.head = <ul>
10.1.tail = </ul>
10.1.rbeg = <li>
10.1.rend = </li>

Will display a list with two entries, where only in the second the variable is replaced correctly:
  • hallo {{second:R::s}}
  • hallo absolventenLogin

Using 5.sql = in the first line fixes the problem, so it seems the subquery call somehow messes up the numbered queries...


Related issues

Is duplicate of QFQ - Bug #3333: Subquery-Fehler auf ReportsClosedElias Villiger10.03.2017

Actions
#1

Updated by Carsten Rose about 2 years ago

  • Is duplicate of Bug #3333: Subquery-Fehler auf Reports added
#2

Updated by Carsten Rose about 2 years ago

  • Status changed from New to Closed

Wurde schon gefixt.

Achtung: 18.10.2 hat aktuell Probleme mit dynamic update wenn Zeilen ein/ausgeblendet werden.

CU
Carsten

Also available in: Atom PDF