Project

General

Profile

Feature #7744

Confirm delete for Subrecords

Added by Nicola Chiapolini almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
-
Start date:
25.01.2019
Due date:
% Done:

0%

Estimated time:
Discuss:

Description

It would be nice if the delete button shown by a form-element of type "subrecord" could trigger a confirmation-alert to prevent accidental deletes. (ideally one should be able to activate/deactivate this via paramerters).

(If this is implemented, I did not find it in the documentation)


Files

subrecord_delete.png (35.5 KB) subrecord_delete.png Carsten Rose, 25.01.2019 18:25
#1

Updated by Carsten Rose almost 2 years ago

Dear Nicola

in our setup there is confirmation dialog. Please check if you have any JS errors.

CU
Carsten

#2

Updated by Nicola Chiapolini almost 2 years ago

Thanks, yes I see the dialog as well now. I have no idea what went wrong last week... Sorry for the noise.

#3

Updated by Carsten Rose almost 2 years ago

  • Status changed from Feedback to Closed

BTW: if you open the 'delete' link a new tab (e.g. by pressing the middle mouse button) ... there is no confirmation dialog. This is caused by the browser not submitting a regular 'onClick()' event.

Also available in: Atom PDF