Project

General

Profile

Bug #7639

Updated by Carsten Rose over 1 year ago

* Im FormEditor bei den FE funktioniert das Drag and Drop in Subrecords. alles.
* Auf dem MI-Tool, bei den Settings (form=setting)

* im Setting 'Misc', koennen die Subelements ebenfalls sortiert werden.
* im Setting 'Finanzierungsform', gibt es folgenden Fehler:

<pre>
UniqId:: 5c3ba456e2e68
------------------------------------------------
toUser:: Expected one row, got 0 rows
Timestamp:: 2019.01.13 21:49:26 +0100
Code:: 2008
Message:: Expected one row, got 0 rows
Type:: Db Exception
SQL final:: SELECT * FROM Form WHERE id = ?
SQL Params:: array (
0 => '257',
)
current sip:: array (
'__dbIndexData' => '0',
'dnd-subrecord-form-id' => '257',
'dnd-subrecord-id' => '833',
'dndTable' => 'Ggroup',
'orderColumn' => 'ord',
'orderInterval' => '10',
'r' => '0',
's' => '5c3b9f821f3bc',
'urlparam' => '__dbIndexData=0&dnd-subrecord-form-id=257&dnd-subrecord-id=833&dndTable=Ggroup&orderColumn=ord&orderInterval=10&r=0',
)
Page Id:: -
FE User:: crose
File:: /var/www/html/mi/typo3conf/ext/qfq/Source/core/database/Database.php
Line:: 238
IP Address:: 192.168.133.210
HTTP User Agent:: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.102 Safari/537.36 OPR/57.0.3098.102
QFQ Cookie:: nssntptvrji46sgclf1c77aboc
Stacktrace::
#0 /var/www/html/mi/typo3conf/ext/qfq/Source/core/store/Store.php(909): qfq\Database->sql('SELECT * FROM F...', 'expect_1', Array)
#1 /var/www/html/mi/typo3conf/ext/qfq/Source/core/QuickFormQuery.php(1587): qfq\Store::fillStoreWithRecord('Form', '257', Object(qfq\Database))
#2 /var/www/html/mi/typo3conf/ext/qfq/Source/api/dragAndDrop.php(61): qfq\QuickFormQuery->dragAndDrop()
</pre>

Weitere Beobachtung:

* Auf webwork16/crose/qfq ist das Drag and Drop ok.
* Auf w16/my liefert es den oben genannten Fehler.
* Wird webwork16/crose/qfq auf MultiDB umgestellt, kommt zwar nicht der Fehler, das Drag and Drop funktioniert nicht - nach einem Refresh haben die FE noch die alte Ordnung.

Back