Project

General

Profile

Actions

Feature #2361

closed

Logging wer/wann/wo welches Formular aufgerufen hat

Added by Carsten Rose over 7 years ago. Updated 4 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
Carsten Rose
Target version:
-
Start date:
18.08.2016
Due date:
% Done:

0%

Estimated time:
4.00 h
Discuss:
Prio Planung:
No
Vote:

Description

  • Damit man fesstellen kann welche Formulare aktiv genutzt werden, sollte in der History (wer wann was wo geaendert hat) auch das Formular drin stehen, inkl. aktueller Seite wo es geladen wurde und den Referrer (von wo der Aufruf kam). Bereits umgesetzt.
  • Pro Form kann es einen Button 'History' geben - dort sieht man alle Aenderungen (Enduser).
  • Gutes Diff um die Aenderungen visuell hervorzuheben.
  • Evtl. wird das gleich beim Speichern gemacht - der Record wurde sowieso geladen. Es muesste also leicht moeglich sein alt und neu zu vergleichen und das Delta in die 'diff' spalte zu schreiben.
  • ggfs. mit einem Undo Button?
    • Falls 'before/after save' FE existieren evtl. eine Warnung ausgeben.

Related issues

Related to QFQ - Feature #4432: Save whole 'Form Submit'-request as JSON in a logClosedElias Villiger09.09.2017

Actions
Is duplicate of QFQ - Feature #7480: Record History (Undo / Redo)ToDoZhoujie Li13.12.2018

Actions
Actions #1

Updated by Carsten Rose over 6 years ago

  • Tracker changed from Support to Feature
Actions #2

Updated by Carsten Rose over 6 years ago

  • Target version set to next9
Actions #3

Updated by Carsten Rose over 5 years ago

  • Target version changed from next9 to 18.10.3
Actions #4

Updated by Carsten Rose over 5 years ago

  • Subject changed from Logging wer/wann/wo welches Formular aufgerufen hat: Tabelle 'history' to Logging wer/wann/wo welches Formular aufgerufen hat
  • Description updated (diff)
Actions #5

Updated by Carsten Rose over 5 years ago

  • Related to Feature #4432: Save whole 'Form Submit'-request as JSON in a log added
Actions #6

Updated by Carsten Rose over 5 years ago

  • Target version changed from 18.10.3 to 18.12.1
Actions #7

Updated by Carsten Rose about 5 years ago

  • Target version changed from 18.12.1 to 141
Actions #8

Updated by Carsten Rose about 5 years ago

  • Estimated time set to 4.00 h
Actions #10

Updated by Carsten Rose almost 5 years ago

  • Priority changed from Normal to High
  • Target version changed from 141 to 146
Actions #11

Updated by Carsten Rose over 4 years ago

Actions #12

Updated by Carsten Rose over 4 years ago

  • Target version changed from 146 to next6
Actions #13

Updated by Carsten Rose over 4 years ago

  • Priority changed from High to Normal
Actions #14

Updated by Carsten Rose over 4 years ago

  • Description updated (diff)
Actions #15

Updated by Carsten Rose about 4 years ago

  • Status changed from New to Some day maybe
Actions #16

Updated by Carsten Rose about 4 years ago

  • Status changed from Some day maybe to New
Actions #17

Updated by Carsten Rose 4 months ago

  • Description updated (diff)
  • Prio Planung set to No
Actions #18

Updated by Carsten Rose 4 months ago

  • Description updated (diff)
Actions #19

Updated by Carsten Rose 4 months ago

  • Related to deleted (Feature #7480: Record History (Undo / Redo))
Actions #20

Updated by Carsten Rose 4 months ago

  • Is duplicate of Feature #7480: Record History (Undo / Redo) added
Actions #21

Updated by Carsten Rose 4 months ago

  • Status changed from New to Rejected

Wird in #7480 behandelt

Actions #22

Updated by Carsten Rose 4 months ago

  • Target version deleted (next6)
Actions

Also available in: Atom PDF