Project

General

Profile

Bug #2542

FormElement-Typ 'note' funktioniert nicht mit dynamic update

Added by Elias Villiger almost 4 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
-
Start date:
26.09.2016
Due date:
% Done:

0%

Estimated time:
Discuss:

Description

Ein FormElements von Typ 'note' wird durch dynamic update code nicht aktualisiert.

Associated revisions

Revision 318f0f30 (diff)
Added by Carsten Rose over 3 years ago

#2542 / FormElement-Typ 'note' funktioniert nicht mit dynamic update
''abel' and 'note' are fixed - 'value' is still not updated, open.
HelperFormElement.php: buildFormElementName() had some issue if there was no $formElement[FE_NAME] defined. New workaround: take the $formElement[FE_ID] instead.
AbstractBuildForm.php: creation of JSON has been missed - now fixed. The $value is rendered (recent value), but probably the client is not prepared to update a non-HTML-input field. This has to debug with RO.

Revision 71fc9567 (diff)
Added by Carsten Rose about 3 years ago

#2542 / FormElement-Typ 'note' funktioniert nicht mit dynamic update
With API 'update-element' & 'content' also the 'input' column for FE.type='note' will be updated.

Revision 25ea9583 (diff)
Added by Carsten Rose about 3 years ago

#2542 / FormElement-Typ 'note' funktioniert nicht mit dynamic update
Fix problem that also non-'note' FE's has been updated.

History

#1 Updated by Elias Villiger over 3 years ago

  • Priority changed from Normal to High

#2 Updated by Carsten Rose over 3 years ago

  • Is duplicate of Feature #2081: Form: Label & Bemerkung via Dynamic Update aktualisierbar. added

#3 Updated by Carsten Rose over 3 years ago

  • Status changed from New to Closed
  • Priority changed from High to Normal

#4 Updated by Carsten Rose over 3 years ago

  • Is duplicate of deleted (Feature #2081: Form: Label & Bemerkung via Dynamic Update aktualisierbar.)

#5 Updated by Carsten Rose over 3 years ago

  • Status changed from Closed to In Progress

Hallo Carsten

Das Ticket #2542 ist geclosed, aber funktioniert für mich noch nicht. Es handelt sich dabei nicht um ein Duplicate von #2081 (wie im Ticket fälschlicherweise steht).

Es geht darum, dass ein FormElement vom TYPE 'note' momentan nicht mit dynamic update funktioniert (also auch nicht, wenn der entsprechende Code z.B. ins Feld 'value' des FormElements vom Typ 'note' eingetragen wird).

Macht das Sinn?

Ich schreibe dir das per Mail, weil ich den Ticket-Status nicht mehr verändern kann (steht für mich fix auf Closed).

Danke und liebe Grüsse
Elias

#6 Updated by Carsten Rose over 3 years ago

Testformular: http://qfq.math.uzh.ch/crose/qfq-jqw/ / noteDyn2542

#7 Updated by Carsten Rose over 3 years ago

'label' und 'note' werden nun aktualisiert.
'value' ist noch offen >> mit RO anschauen.

#8 Updated by Elias Villiger over 3 years ago

  • Priority changed from Normal to High

#9 Updated by Carsten Rose about 3 years ago

Um 'value' (=input) zu aktualisieren:

  • Die 'id' fuer den Fake 'input' Part wird nicht korrekt berechnet. (im JSON)
  • Des Fake 'input' Element (ein div) hat gar keine ID.
  • Das anschliessende JSON (via load.php) uebermittelt den Text in 'value'. Laut RO sollte das Attribute 'content' heissen.

#10 Updated by Carsten Rose about 3 years ago

  • Status changed from In Progress to Closed

'Value' fixed too.

#11 Updated by Elias Villiger about 3 years ago

  • Priority changed from High to Normal

Also available in: Atom PDF