Project

General

Profile

Actions

Bug #7014

open

Sending invalid emails succeeds when debug.redirectAllMailTo is set

Added by Nicola Chiapolini almost 4 years ago. Updated over 2 years ago.

Status:
New
Priority:
Normal
Assignee:
Carsten Rose
Target version:
Start date:
16.10.2018
Due date:
% Done:

0%

Estimated time:
Discuss:
Prio Planung:

Description

When debug.redirectAllMailTo is set, mails work without error even if they are sent to invalid mail addresses.
This makes spotting problems in development harder. It's probably hard to avoid this, but it might be useful to highlight this downside in the documentation.

(#7013 prevented the sending of emails in our latest feature in production. Since the feature sends several identical emails we never noticed the mails with invalid to adresses in development - and it took a while to realize the bug really was present there as well.)

Actions #1

Updated by Carsten Rose almost 4 years ago

  • Target version set to 18.10.3
Actions #2

Updated by Carsten Rose almost 4 years ago

  • Target version changed from 18.10.3 to 18.12.1
Actions #3

Updated by Carsten Rose almost 4 years ago

check ob to,cc,bcc syntaktisch korrekte email adressen enthalten.

Actions #4

Updated by Carsten Rose almost 4 years ago

  • Target version changed from 18.12.1 to 141
Actions #5

Updated by Carsten Rose almost 3 years ago

  • Status changed from New to Some day maybe
Actions #6

Updated by Carsten Rose almost 3 years ago

  • Status changed from Some day maybe to New
Actions #7

Updated by Carsten Rose over 2 years ago

  • Assignee set to Carsten Rose
Actions #8

Updated by Carsten Rose over 2 years ago

  • Target version changed from 141 to next8
Actions

Also available in: Atom PDF