Project

General

Profile

Bug #7014

Sending invalid emails succeeds when debug.redirectAllMailTo is set

Added by Nicola Chiapolini over 1 year ago. Updated 4 months ago.

Status:
New
Priority:
Normal
Assignee:
Target version:
Start date:
16.10.2018
Due date:
% Done:

0%

Estimated time:
Discuss:

Description

When debug.redirectAllMailTo is set, mails work without error even if they are sent to invalid mail addresses.
This makes spotting problems in development harder. It's probably hard to avoid this, but it might be useful to highlight this downside in the documentation.

(#7013 prevented the sending of emails in our latest feature in production. Since the feature sends several identical emails we never noticed the mails with invalid to adresses in development - and it took a while to realize the bug really was present there as well.)

History

#1 Updated by Carsten Rose over 1 year ago

  • Target version set to 18.10.3

#2 Updated by Carsten Rose over 1 year ago

  • Target version changed from 18.10.3 to 18.12.1

#3 Updated by Carsten Rose over 1 year ago

check ob to,cc,bcc syntaktisch korrekte email adressen enthalten.

#4 Updated by Carsten Rose over 1 year ago

  • Target version changed from 18.12.1 to 141

#5 Updated by Carsten Rose 6 months ago

  • Status changed from New to Some day maybe

#6 Updated by Carsten Rose 6 months ago

  • Status changed from Some day maybe to New

#7 Updated by Carsten Rose 4 months ago

  • Assignee set to Carsten Rose

#8 Updated by Carsten Rose 4 months ago

  • Target version changed from 141 to next3

Also available in: Atom PDF