Project

General

Profile

Feature #7883

Link to QFQ record: '... AS _qfq'

Added by Carsten Rose almost 3 years ago. Updated 9 months ago.

Status:
Rejected
Priority:
High
Assignee:
Target version:
Start date:
14.02.2019
Due date:
% Done:

0%

Estimated time:
Discuss:

Description

Z.B. fuer PDFs Download-Buttons, die an mehreren Stellen verwendet werden aber mehr oder weniger identisch sind, waere es gut wenn man einen solchen Record in einem anderen Report einblenden koennte.

Bsp.: Ein Report mit Rows. Eine der Spalten enthaelt einen PDF download Button. Der gleiche PDF Download Button wird auch noch an anderer Stelle im Tool verwendet.

In der Download Button Spalte wid anstelle von "'d:test.pdf|F:file1|F:file2|...' AS _pdf" ein Target angegeben: "'Q:1234&p=21&reId=23...' AS _link" (oder as _qfq) wobei '1234' die tt_content uid ist. Wird anstelle von '1234' ein Text angegeben ist das ein pagealias. Fe-Group, start/end, disable werden nicht ausgewertet. Beachtet wird 'delete'.

Parameter werden via SIP Store (gefaked) uebergeben. Auch ist der RECORD Store noch vorhaden. SIP und RECORD Store werden nach der Ausfuehrung wieder hergestellt.

Der vollstaendige Output des eingebundenen Records wird an der Stelle von '... AS _qfq' eingefuegt. In Falle eines PDF muesste das also ein Download Button sein.


Related issues

Is duplicate of QFQ - Feature #11998: Custom QFQ-FunctionClosedCarsten Rose11.02.2021

Actions
#1

Updated by Carsten Rose almost 3 years ago

  • Priority changed from Normal to High
#3

Updated by Carsten Rose almost 3 years ago

  • Status changed from New to In Progress
#4

Updated by Carsten Rose almost 3 years ago

  • Status changed from In Progress to New
#6

Updated by Carsten Rose over 2 years ago

  • Status changed from New to In Progress
#7

Updated by Carsten Rose over 2 years ago

  • Status changed from In Progress to New
#8

Updated by Carsten Rose over 2 years ago

  • Target version changed from 146 to QFQCD19 - waere gut
#9

Updated by Carsten Rose over 2 years ago

  • Target version changed from QFQCD19 - waere gut to 22.5.0
#10

Updated by Carsten Rose over 2 years ago

  • Status changed from New to In Progress
#11

Updated by Carsten Rose over 2 years ago

  • Status changed from In Progress to New
#12

Updated by Carsten Rose almost 2 years ago

  • Status changed from New to Some day maybe
#13

Updated by Carsten Rose almost 2 years ago

  • Status changed from Some day maybe to New
#14

Updated by Carsten Rose almost 2 years ago

  • Description updated (diff)
#15

Updated by Carsten Rose 9 months ago

#17

Updated by Carsten Rose 9 months ago

#18

Updated by Carsten Rose 9 months ago

#19

Updated by Carsten Rose 9 months ago

  • Status changed from New to Rejected
  • Target version changed from 22.5.0 to 22.4.0
#20

Updated by Carsten Rose 9 months ago

  • Target version changed from 22.4.0 to 21.3.1

Also available in: Atom PDF